Heartbleed vulnerability

heartbleed

We would like to assure users that our systems have been upgraded to patch the Heartbleed OpenSSL vulnerability and there is no reason for users to change their passwords.

It is always recommended to use strong passwords for any websites with sensitive data, in the case of Dr Fox this is personal medical and health data (no payment card data is stored on our server). If you wish to change your password please login to your account.

You can verify the Heartbleed patch for www.doctorfox.co.uk here.

Further information on Heartbleed.